Meow Lightbox

Lightbox made for and by photographers

Meow Lightbox has been made for and by photographers. It’s clean, beautiful, the options are simple and straightforward.

Meow Lightbox

If you want to see how it performs, have a look at one of my post on my website, for example, this one: Best Abandoned Places in Japan.

Pro Version

The Pro version adds preloading of the next images and will add more functions in the future.

Usage

Selector

By default, the selector is set on ‘.entry-content’. This selector represents the CSS elements in which the lightbox will look for images and does its magic. Depending on the theme, or what you exactly need, the selector might be different. Check the FAQ below if you are confused.

Edit Post / Page

When you insert images in your posts, make sure the “Link To” is set to “Media File” or to “Attachment Page“.

FAQ

How to find the CSS selector?
You can start to have a look at this video: https://www.youtube.com/watch?v=V2aAEzlvyDc. This shows you how to use Chome Developer Tools to browse your HTML. You need to find the element (probably a <div> or a <section>) that contains all your content and images. When you find this one, have a look at its id=”xxx” or class =”yyy”. Then your selector will be either “xxx” or “.yyy” (CSS classes start with a dot).
  • Chris

    Hi Jordy, would it be hard to get this plugin work with woocommerce products?

    • I don’t think it would be hard, but it doesn’t work right now? Sorry, I don’t use WooCommerce so basically I don’t test my plugins with it much ๐Ÿ™‚

      • Chris

        OK. Thanks for your reply Jordy

  • Maik Buschbacher

    Hi Jordy How can i Figure out if My theme use the .entry-content ?? i want to Use your lightbox with the Hugeit gallery ( https://huge-it.com/wordpress-gallery/) could you help me ?

    • Thomas Kim

      Hello Maik !

      Thomas here, I’m the co-author of this plugin so let me help you on this question ๐Ÿ™‚

      To know what class to put in the selector setting, you will have to inspect the source code of your page ( with the gallery ).

      If you don’t know how to do it, you can give me the url of your website / page where you want to enable the lightbox and I’ll give the right selector to you ๐Ÿ™‚

      Hope I could help !

      Thomas

      • Maik Buschbacher

        http://Www.picass-o.com is the Adress. Ive wrote hugeit Support so they can deactivate their lightbox

        • Thomas Kim

          Ok, I think you can try by replacing .entry-content with .huge_it_gallery_container ( it will only work with galleries, not on single photos ).

          • Maik Buschbacher

            Badly it doesnยดt work …

          • Thomas Kim

            Oh really ? the lightbox is not triggering ?
            Could you give me the exact content of the “selector” setting ( copy / paste it ) please ?

          • Maik Buschbacher

            “.huge_it_gallery_container” The ” was input from me ^^ if you want, you can give me an email so that i could acess you admin rights to solve that problem ?

          • Maik Buschbacher

            I tested something … If i Create an Gallery in the Media Section , the Selector “.gallery” works… But for my Reasons i need an Rating System in the gallery … so would it be possible to add an Trafficlight ( that would be awesome ) or an 5 Star Rating System in the Lightbox ? If that would be Possible iยดm willing to donate for it because this would be Perfect <3

          • Thomas Kim

            Hello Maik !

            Haha yeah I understood that the ” was from you, but it’s worth telling ๐Ÿ˜‰

            I shouldn’t need admin rights for that I think, but I’ll let you know if it’s necessary.

            Aaaah actually I would love a ranking system myself, but without being too technical, it would be a bit out of the scope of a Lightbox ! ( we would have to change medias in the database etc.. ). We have already started to think about doing a plugin allowing “custom likes” ( not facebook likes ) on pictures, that would of course work with our Lightbox. However, it’s only just an idea we have for now and I think it won’t be available until some time as we are working hard on our current plugins !

            If you have any other suggestion please feel free to post them here ๐Ÿ™‚

            Best regards,

          • Maik Buschbacher

            So i have to add the lightbox to the hugi-it gallery ๐Ÿ˜€

          • Thomas Kim

            Oh sorry ! I thought you were fine with the native gallery !

            Hmm if .huge_it_gallery_container doesn’t work, can you try with : .page, .single-post

            It should work on your pages / single posts this way.

            However, I think the problem might not come from the selector but from the lightbox included with Huge-it gallery !

            Cheers,

          • Maik Buschbacher

            No this selectors dont Work Too… I should search for an Other gallery… To Bad that You dont have A rating inside ๐Ÿ™ Maybe You have an idea for A gallery that fit my Problems? ^^

          • Thomas Kim

            Yeah I think this is definitely a problem with their included lightbox ..

            Hmm I don’t know other galleries with a rating system, but maybe you could find a dedicated plugin that could do it ?

            Of course I would recommend our own gallery “Meow Gallery” for the layout, it’s made to work seamlessly with Meow Lightbox !

            Hope I could help,

          • Maik Buschbacher

            Thanks for your Help Anyway… Iยดve testet so many things but the Hugeit gallery wouldnยดt fit with the Lightbox. Even they Deactivate their Lightbox Couldnยดt include the Meow lightbox to fix the Problem … but i think i would stand by your Gallery and Lightbox and try to add a Rating to it.. ( if i could find out how ^^ ) dont wanna use 3rd party services anyway ^^

  • Hello Jordy and Thomas,

    I’ve just installed your plugin (already using WP/LR Sync too) and it looks really neat and I think I’ll stick with it, thank you for your work!

    There are some things though I’d like to suggest:
    1) (Photography layout) I don’t really how landscape orientated pictures attach at the top, directly to the browser bar. A little space, maybe?
    2) (Photography layout) I think the balance between the text informations at the bottom and the picture above are a little bit off. I have the feeling that the text information is too dominant here. Maybe that changes if you apply suggestion #1.
    3) The position of the navigation arrows changes position when changing from a landscape to portrait orientated picture. I suggest the arrows to be always at the same position (vertical middle, on the far left/right?)
    4) I’m using wp-captions with my pictures (custom capture in the blog post, not attached as a media description) and sadly, this isn’t shown within the lightbox. It would be nice if custom captions could be shown, too.

    Thanks for reading!

    Christian

    • Thomas Kim

      Hello Christian !

      Thank you for using our plugins, we are glad that you like them !

      About your suggestions :

      Photography Layout : Indeed, there is no padding at the top, I will definitely try to add a small padding there ( can’t do a big one though, as we want the image to be as big as possible, that’s a lightbox goal after all haha ), I will also check the balance between image height / infos height, but it’s hard to find a good one as it actually depends on the amount of infos there is ๐Ÿ™‚

      Navigation Arrows : That’s true, however if we do that, the right arrow on portrait pictures will be above text, which doesn’t seem very intuitive for me ? I will try to find a solution but I can’t guarantee you anything yet !

      Captions : I think this is a good idea, and we might be able to add this in a futur update for sure ! ( can’t give you a precise date yet though as there is many other things we are currently trying to add ! )

      Best regards,
      Thomas

      • Hello Thomas,

        thanks for your reply and consideration of my suggestions.

        Navigation arrows: I’ve meant putting the arrows at a fixed position at the vertical middle and at the same time, on the far side, while the content is between the arrows. I’ve made a screenshot for making my point more clear ๐Ÿ™‚

        https://uploads.disquscdn.com/images/f3fb502ebfcf1832139b23684266bb4154817dfc3e2a972e952c9bff85f70462.png

        • Thomas Kim

          No worries, thank you for making suggestions ! That’s what we need to make this plugin better and fit photographers as well as possible !

          Actually that’s what I understood already, but in your screenshot, there is no description for the photo, so it looks ok to move the arrow, but if there is one, this is a bit more tricky.

          However, I just checked it right now, and I will think about it again, it’s not that bad and it could improved the UX ๐Ÿ™‚

          Thank you for these suggestions !

          Thomas

          • Hm, sorry, I don’t really understand your point. I’ve just added a description for testing purpose and the description appears between the title and exif informations, as expected. The space is available even when shrinking the screen space to the minimum before the exif informations disappear. From a simple html point of view, it shouldn’t be that difficult to implement.

            But ok, I didn’t take a look at the code, so I just hope for an update for now ๐Ÿ™‚

            https://uploads.disquscdn.com/images/4c0d8419e0d82acadf94697d8d31afaefd7758520562c6c3d654290bf1c3c63e.png

            https://uploads.disquscdn.com/images/ebfbe3a796ac4c373cd335d1670ac16b7308f6291bc6589ee2d58228df87f8a7.png

          • Thomas Kim

            Hahaha you are right, there is a padding on the right, but the description you’ve added is really shot, if you try with a very long one, the arrow will be very close to the text.
            My point is that navigation is to change images, so I was thinking that putting the arrows on images was the smartest way to do it.
            However, as I’m personally using keyboard to navigate, I never really realized how frustrating it was, these moving arrows. So I’m now really thinking about doing it as you suggest ( fixed arrows, no matter the orientation ).

  • Terry Kahler

    Hi Jordy/Thomas. I’m struggling also to find the right settings. I’m a big user of the WP/LR plugin and I would really like to use this one as it solves some challenges I have been having. Can you help me determine the right selector settings for my theme (Oyster)? I have created a test page at http://tkahler.com/blog/test-page/. Many thanks.

    • Thomas Kim

      Hello Terry Kahler,

      I had a look at your page, from this page I think you could use the selector “.contentarea” ๐Ÿ™‚

      Hope I could help !

      Best regards,
      Thomas

      • Terry Kahler

        Thanks Thomas. It worked. A few observations;
        a) It seems to take a lot longer to load the page when I have the plugin activated.
        b) If you click on any part other than the plugin arrows it defaults back to the native Lightbox.
        c) It appears that the first text is the caption and the text below is the title. Can we get those reversed? I say that because the gallery page uses the caption at the bottom. Or, it would be best to use “Description” for the second one. See the way It looks on my test page.
        d) I support the recommendations of Japan-Kyoto.
        Thanks again for your help.

        • Thomas Kim

          Hello Terry,

          a) Hmm this is indeed strange, as the plugin is normally loaded at the very end of the page along with other wordpress plugins. I will have a closer look at your website and come back to you.

          b) native lightbox ? WordPress doesn’t have any native Lightbox, do you have an other plugin ? Maybe it’s included in your theme ?

          c) Hmm that’s actually a very good observation ! I’ll tell Jordy about it ( he is the one dealing with the back-end ๐Ÿ˜‰ ).

          d) Understood ! I’m working on them right now, most should be available in next update ๐Ÿ™‚

          Thank you for taking some time to make these suggestions / remarks !

          Cheers,

          • Terry Kahler

            You are welcome. Happy to help in any way. By native I meant the theme’s Lightbox.

          • Thomas Kim

            Oh I see, unfortunately, I don’t think there is much we can do about it ( we can’t decide for your theme not to open another lightbox ), but maybe there is an option somewhere on your theme to disable it ?

          • Terry Kahler

            OK. It’s fairly confusing from a user perspective to click in the wrong place and change the Lightbox. Not sure if I can disable the theme’s Lightbox but I will give it a try.

          • Thomas Kim

            Yes, I understand your point,

            I had another idea if you can’t find an option to disable it, we can simply hide it through CSS.

            You can add the following code to your theme custom CSS file :

            .mfp-wrap {
            display: none !important;
            }

            .mfp-bg {
            display: none !important;
            }

          • Terry Kahler

            Thanks Thomas. That worked but once I click off it will not let me restart the box again. Perhaps I put it in the wrong place. I have a child theme and I put it in style.css

          • Thomas Kim

            Hello Terry,

            Hmm I checked your website, I think the code is ok, but there must be something else to disable.. have you tried contacting the theme author to ask him how you could disable his lightbox ?

          • Terry Kahler

            Thanks Thomas. I will do that shortly. There is another Lightbox that comes with the theme. Perhaps that one works better. Can you check out this page ( http://tkahler.com/blog/austin-live-music/ ) and let me know what the settings would be for that one?

          • Thomas Kim

            Very sorry for the late reply Terry !

            You might want to try : “.contentarea” as a selector ๐Ÿ™‚

            Sorry again for the late reply !

          • Terry Kahler

            Thanks Thomas. No worries. That’s the current selector but it does not bring up the Lightbox. I could not find another one though. Thanks for your help.

  • Saxman Woodwind

    Hi As a new WP user I am trying to make a photo WP site,as have your gallery & lightbox. But when I load the gallery code into a page,it does not work? On single images your lightbox works ok it seems. If I make a gallery with say Huge IT ,it loads fine?? what I am doing wrong Thanks Shanti

    • Thomas Kim

      Hello Shanti,

      Could you explain me what exactly doesn’t work when you “load the gallery code into a page” ๐Ÿ™‚ ? Is it the gallery, the lightbox, both .. ?
      ( Actually I don’t exactly understand what you mean by “loading” the “gallery code” into a page ? )

      Best regards,
      Thomas

      • Saxman Woodwind

        Hi sorry new to WP .. Gallery is made in Photo Gallery WP & then I put code into my page https://uploads.disquscdn.com/images/4f79cc6408bb319811501ed4ee43af1b9478484c148f6220ec85a99ad8b5c229.jpg

        • Thomas Kim

          Oh I see, could you send me a link to one of your website page where it doesn’t work ?

          • Saxman Woodwind

            Hi its not done yet.. have to figure out how to remove extra menus & post box in middle..but probably no effect on galleries?? on swans..I can see the pics but no navigation/lightbox effects? but on the other ones..like garden birds..it works with exif & navigation

          • Saxman Woodwind

            forgot the link ๐Ÿ˜‰ http://www.danskefugle.dk/svane-swans/ any way to make gallery 4-5 rows across ,instead of 2…

          • Thomas Kim

            Hello, I had a look at your page, hmm you seem to have a lot of plugins installed ! On Swan there is only one lightbox ( not ours ), I guess it’s the one from the gallery ?
            But on Birds in the garden, the gallery is different but when I click I have 2 lightboxes ( none of them is ours either ).

            I would recommend you not to use a gallery plugin like Photo Gallery WP, but instead just use the native wordpress gallery ( and eventually use our own plugin Meow Gallery to style this native gallery, it works out of the box, it’s very easy ).

            It would highly simplify everything I think ! But maybe you have reasons for using a specific gallery manager plugin like Photo Gallery WP over the native ( very good ) WordPress gallery ?

            Cheers,
            Thomas

          • Saxman Woodwind

            Hi here is a page with yours http://www.danskefugle.dk/waterfowl/
            as I am learning WP,just experimenting now,should I disable all plugins? I thought Photo Gallery WP was the WP one? if not which on is? just want a gallery/ ligthbox w/ exif & name & possible to buy w/ Paypal ..not so much blogging.. Thanks Shanti

          • Saxman Woodwind

            Hi now it works with your lightbox,anyway to have photo in center instead of on top? http://www.danskefugle.dk/svane-swans/ Thanks

          • Thomas Kim

            Hello, you can change the lightbox layout in the plugin settings ( dashboard / MeowApps / MeowLightbox ) to center the image ๐Ÿ™‚

  • Hello again,

    while checking my site with tools.pingdom.com, I’ve noticed more http requests than usual. Although I’m not sure, I suspect your plugin of being the reason for it. In the details, there are several entries:
    “https://japan-kyoto.de/wp-json/mwl/v1/info/12959
    https://japan-kyoto.de/wp-json/mwl/v1/info/12961
    https://japan-kyoto.de/wp-json/mwl/v1/info/12964
    https://japan-kyoto.de/wp-json/mwl/v1/info/12965
    https://japan-kyoto.de/wp-json/mwl/v1/info/12966
    https://japan-kyoto.de/wp-json/mwl/v1/info/12969
    Related site: https://japan-kyoto.de/entokuin-subtempel-kodaiji-kyoto/

    If your plugin is the reason for this, I’d like to kindly ask you to reduce or remove altogether those requests, if possible. Thanks!

    • Thomas Kim

      Hello again Christian,

      Indeed, it’s our plugin making these calls.

      This is actually our way to retrieve Exif datas ( as you can see in the response ), so … unfortunately we can’t really remove them. However, Jordy might be able to give you a more detailed answer !

      I will try to think of a way to optimize these calls in the meantime !

      Sorry for the inconvenience,
      Thomas

      • Hello Thomas,

        no need for a more detailed answer! It’s already enough if you try to optimize them, thanks!

      • I just noticed something else and sadly, I had to disable the plugin because of this for now. No hyperlink with an enclosed image worked anymore. HTML was fine, but clicking on the image didn’t do anything. Tested in Chrome and Firefox.

        • Thomas Kim

          I see what’s your problem, this is actually the reason of the “selector” setting, if set correctly, you can decide precisely where the lightbox should work or not, right now, your “normal” links are considered as lightbox images, that’s why it doesn’t work. But if we reduce the scope of the lightbox to exactly what you need, then it should work just fine.

          If you want to continue using our plugin, I would be glad to help you find the right selector for your website !

          Best regards,
          Thomas

          • Ah, I see, the selector causes trouble. I’ve activated it again with another selector and I don’t have troubles anymore with linked images on my starting page. Still, I have external images embedded on my side which link still doesn’t work and neither show up in the lightbox (because…external?). Example external images: https://japan-kyoto.de/tempel-shorenin-kyoto/

            To perfectly capture all my pictures, I’d need two selectors: .divimg and .wp-caption. For now, it’s .post (which excludes .page, as that would break my starting page).
            Before, it was .post-content, which included posts and pages.

          • Thomas Kim

            Yes, the selector is a very powerful setting, but it’s a bit hard to understand at first, especially for people who have never see a line of code before ! I’m writing a small tutorial for it, should be added to this page soon.

            And once again you are right, unfortunately the lightbox doesn’t work with external images. The reason is that basically we retrieve all datas from WordPress, and WordPress doesn’t create any datas for images from an external source.

            We could add the support for these external images but it would be a lot of work. I’ll keep it in mind but for now I’d like to focus on all the other suggestions you’ve made !

            Cheers,
            Thomas

          • What a neverending story. I noticed then when I use .post as a selector, it will affect thumbnails in archive view! -_-
            I then went ahead and simply chose several selectors, for now ‘.divimg, .wp-caption, .gallery’ and intended or not, this actually works! Seems like a good setup now ๐Ÿ™‚
            Maybe the help text should be changed to “This selector (or selectors, comma separated) will be used to apply the lightbox to the images.”

  • Hi, thank you for this free good plugin. I love the selector setup “.entry-content”, can’t find in other free plugin as far as i search on wordpress site.

    To make this plugin become better, i concern with the quality image in the lightbox. With screen resolution 1920×1200, quality of 1920×1080 image not good as the other lightbox plugin.

    I tested with rendered cg image without EXIF data, the image seems stretched out to maximum screen size. Smaller image also stretched out to fit the screen resolution which is destructing the quality of original image to be seen.

    My suggestion for future update:
    1. Improve the quality of lightbox image. It’s the must.
    2. First pop up image, if original image smaller than screen resolution, then keep it original. If original image bigger than screen resolution, then keep it fit to screen resolution with zoom in/out tools to see the detail of the image later. So visitor may see the real quality of original uploaded image.

    I would like to pay with affordable price for above suggestion. Or did i miss something?

    • Thomas Kim

      Hello Afumado,

      Thank you for enjoying our plugin, and glad you like the selector setting haha, we thought it might be a bit too complex for most users.

      Concerning your resolution concerns, we are using the WordPress generated srcset/sizes attributes ( responsive images ), so the resolution displayed should be good ?

      However, it might be an error on our side using these responsive images, even if until your review it looked ok ! I will have a look ๐Ÿ™‚

      PS : No need to pay for a suggestion ! But if you like the plugin and want to help us, a kind review on the wordpress.org plugin page would be awesome !

      Best regards,
      Thomas

  • Zoryana Paliy

    Absolutely loved your plugin at first sight ๐Ÿ™‚ Going to rate it 5-stars on wordpress.org

    • Thomas Kim

      Hello Zoryana,

      Thank you very much ! We are very glad that you are enjoying our plugin, and doing a review on the repository is definitely helping us, so thank you again !

      Best regards,
      Thomas

  • C Kennedy

    Hi, I’m using your masonry gallery and want to link the images to your lightbox, but nothing happens when an image is clicked. I assume its to do with the ‘selector’ setting. I’m using the latest version of WP 4.7.4. with the Twenty Seventeen Theme Can you advise what selector settings I need please?
    Best regards
    Callum

    • Thomas Kim

      Hello C Kennedy,

      I understand your problem, let me help you to find the correct selector !

      Could you please send me the url of your website so that I can check directly ? ( If possible the url of a page containing a gallery ๐Ÿ™‚ )

      Best regards,
      Thomas

  • Jรผrgen Lechner

    Hello,
    i am using Retina WP @2 and the Meow Lightbox – Layout Standard.
    Everything works fine so far. When i click on a preview image within a gallery, the @2 image opens in original size. Is it possible to open the images in 50%? I took a look in the css files and reduced the width and height of the box to 50% which works but the images are no more centered then, they are moved to the left side which does`t look nice. Best regards, Juergen

    • Thomas Kim

      Hello Jรผrgen,

      First of all sorry for the delay, I’m currently moving in another country so I’ve been quite busy these last few days !

      About your problem, actually the lightbox is using responsive images ( which means that the browser decides which image to load depending on the screen size / screen resolution ( retina or not ) ).

      However, we recently fixed an issue preventing images in high-res to be loaded, it will be available along with the next update of the plugin coming very soon !

      If your request is to limit the maximum size, then it’s not possible for the moment, but we could work on an option ( interesting for people who doesn’t want to put high-res pictures available online ).

      Hope I answered your question,

      Best regards,
      Thomas

      • Jรผrgen Lechner

        Hello Thomas,

        many thanks for your reply.

        Understand, but, my images (not@2x) are defined e.g. 600x600px, which look great on non retina displays. For retina displays i have uploaded all @2x images double sized. It makes no sense that the @2x images will be loaded e.g 1200x1200px as they will not look good on retina displays. By the way, if you go to meow-lightbox/css/mwl.css and change the .mwl-container width and height from 100% to 50%, the @2x image will be displayed in 50% and looks sharp as it should be for retina displays. But then, the 50% image is not centered anymore.

        Best regards,

        Juergen

      • Jรผrgen Lechner

        Would you be so kind and reply to my post below.
        Thank you.

  • Grant

    Hi Thomas,

    This is a beautiful implementation! I believe I’ve found the correct selector, because the lightbox does activate on the photos I want. But instead of the photo, it just says “missing image”. Is there something else I need to do? Thanks!

    • Thomas Kim

      Hello Grant,

      Glad you found the correct selector !

      If there is a “missing image”, it means we couldn’t retrieve the image details, is it images from your media library ( ie. not from an url ) ?

      The lightbox doesn’t work with images inserted from an url, maybe this is your problem here ?

      Best regards,
      Thomas

      • Grant

        That must be it. The theme I use has some sort of custom framework to display the images in each portfolio post, and though they’re inserted through WP’s media browser, maybe it can’t find the way they’re referenced. You think the Lightbox wouldn’t work with the image in the screenshot here? https://uploads.disquscdn.com/images/07cc40f91a98a9dc2fb3d537655b8298ce39b9c7eabdc77e830afe234885544d.png

        • Thomas Kim

          Hello,

          Well, if your website url is dotsoncommercial.com the error is coming from something else !

          Could you give me a link to a page of your website where the problem occurs ?

          Best regards,
          Thomas

          • Grant

            Here’s an example of a portfolio page where it can’t load the images: http://dotsoncommercial.com/portfolio/sportsbarn/
            Thanks!

          • Thomas Kim

            I had a look to the website and after discussing it with Jordy, we think the problem comes from your theme framework preventing our plugin to retrieve the image infos.

            I will work on a fix to at least display the image in the standard way ( just a big image, no exif ) in this case, so that the lightbox should work with all images.

            Best regards,
            Thomas

          • Grant

            That would be great, thank you! I planned to used it without exif anyway. Let me know if I can provide anything else to help Thanks!

          • Grant

            Hi Thomas! Wanted to check in and see if you’d had any success finding a way to detect the images without exif in my case. I haven’t upgraded to Pro since it doesn’t actually work on my site yet, but I’m planning to if we can get it sorted out. Thanks for your help!
            – Grant

          • Thomas Kim

            Hello Grant,

            We’ve started to fix it, it should be in the next update of the plugin ( can’t really tell you any precise date as of now, but probably in the month to come ) !

            Cheers,
            Thomas

  • David Plo

    Hello Thomas,

    Glad found your selector!
    I am using your masonry gallery and want to link the images to your lightbox, but nothing happens when an image is clicked. I need help with the css code please.
    My web site is http://www.davidplo.com

    Thanks!

    • Thomas Kim

      Hello David,

      Thank you for using the Meow Gallery !

      I just checked your website and it seems there is another lightbox activated, or maybe I was on a wrong page ?

      Could you send me the url of a page where our lightbox is supposed to work ๐Ÿ™‚ ?

      Best regards,
      Thomas

  • Nels Drugge

    I have a brand new install of WP with the default 2017 theme installed. I have purchased both your lightbox and gallery plugins and installed them, plus I am using your LigthRoom snyc, but when I click on an image with a newly created gallery, it goes to the attachment page and not to lightbox. There are a couple of other questions I have but I don’t want to swamp your forums in a question/answer conversation. Let me know how you would like to proceed.

    • When you insert a gallery in a post, in the settings of this gallery you need to have the “Link To” set to “Media File” otherwise it indeed links to the attachment pages ๐Ÿ™‚ You can use the Contact section on this website.

      • Nels Drugge

        Hmmm. Contact form seems to be crashing both Chrome and Edge. I’ll try from home later. So, quick update. I tried uninstalling everything and reinstalling and figured out that with Lightbox installed on its own it works fine, but as soon as I install Gallery Pro, nothing works. Tried reinstalling a few times and its the same result every time. I have also removed/disabled all other plugins. This is a fresh new install of WP using the default 2017 theme. Tanks so much for your time, and please don’t feel you need to respond immediately while moving. This a personal blog that I’m messing around in. Nothing critical.

  • Hi, there- I love the gallery plugin, and it’s working fine, but not sure why the lightbox isn’t working. I’m using a gallery on this page: http://staging.civiliansinconflict.org/blog/hope-and-despair-amid-the-mosul-campaign, and that works. Lightbox doesn’t. Have changed the selector to .entry-visible, which I think should work, but any advice would be most welcome!

    Thanks,
    Chris

I recommend you to use WPEngine or SiteGround. They are both excellent hosting services and work perfectly with all my plugins.